Not sure if 4.2.2 is vulnerable or not. I am going to try and meet up with the SR folks when I am out next week. Thanks for posting this.